Ask Your Question
0

Help! The enroll link is not working for my students!

asked 2016-01-19 11:39:09 -0500

anonymous user

Anonymous

Some students are enrolled, but others could not enroll even though they received the "enroll" link for my course.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-01-19 11:43:39 -0500

updated 2016-01-19 16:03:53 -0500

Sometimes the Wikipedia login system behaves unexpectedly, especially for brand-new accounts.

In most cases, if it fails the first time then using the enroll link again will allow a student to enroll.

As of mid-January 2016, we're still trying to find a way around this intermittent issue. Here's the expected enrollment flow:

  • Click the enroll link (which ends with ?enroll=somepasscode)
  • If you are not logged in on the dashboard, you'll see an invitation to either log in via Wikipedia or sign up with Wikipedia (if you don't have an account yet). Click one of these.
  • You'll be redirected to Wikipedia, where you need to sign in (if you are not already) and then click 'Allow'.
  • You'll be redirected back to the dashboard. If this is your first time visiting the dashboard, you'll be sent to the onboarding flow where you enter your name and email. After that...
  • You'll be redirected to the original enroll url, which will now have a 'Join' button. (If you are already logged in on the dashboard, you'll see the Join button the first time you visit the enroll link).
  • Click the 'Join' button and you'll be enrolled.

If you run into problems, please let us know what happened. The more details you can provide about where things went off track, the better.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

1 follower

Stats

Asked: 2016-01-19 11:39:09 -0500

Seen: 617 times

Last updated: Jan 19 '16